<!DOCTYPE html>
<html lang="en" itemscope itemtype="http://schema.org/Article" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#
                  article: http://ogp.me/ns/article#">
<head>
    <meta charset="utf-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
    <title>Machine vision depends on open industrial standards - PICMG Systems and Technology</title>
    <link rel="alternate" type="application/rss+xml" title="PICMG Systems and Technology" href="http://m.opensystemsmedia.com/cpci" />
    <link rel="publisher" href="https://plus.google.com/100481914706650211876" />
    <link rel="icon" href="http://cloud1.opensystemsmedia.com/wp-content/themes/osm/images/favicon.ico.gzip" type="image/x-icon" />
    <link rel="shortcut icon" href="http://cloud1.opensystemsmedia.com/wp-content/themes/osm/images/favicon.ico.gzip" type="image/x-icon" />
    <meta name="description" content="">
    <meta http-equiv="Content-Type" content="text/html;charset=UTF-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
    <meta name="viewport" content="width=device-width,initial-scale=1,maximum-scale=1">

            <meta property="og:image" content="http://i.opensystemsmedia.com/?f=jpg&q=85&w=900&src=http%3A%2F%2Fi.opensystemsmedia.com%2F%3Fw%3D450%26f%3Djpg%26q%3D94%26src%3Dhttp%253A%252F%252Fmes-wp-uploads.s3.amazonaws.com%252F5e4c3c002b7f6-NAT%252BErd%252Bposs%252Blead.jpg"/>
        <meta property="og:site_name" content="PICMG Systems and Technology"/>
    <meta property="fb:admins" content="6911118,100001943427940"/>
            <meta property="fb:app_id" content="158637600867272"/>
                    <meta property="og:type" content="article" />                            <meta property="og:description" content=""/>
    <meta property="og:title" content="Machine vision depends on open industrial standards"/>
    <meta property="og:url" content="http://picmg.mil-embedded.com/articles/machine-vision-depends-on-open-industrial-standards/?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+cpci+%28PICMG+Systems+and+Technology+News%29"/>

            <meta name="pubdate" content="20200218" />
    
    <link rel="canonical" href="http://picmg.mil-embedded.com/articles/machine-vision-depends-on-open-industrial-standards/?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+cpci+%28PICMG+Systems+and+Technology+News%29" />
<!--    <link rel="stylesheet/less" type="text/css" href="--><!--/less/--><!--.less?1.0.11">-->
    <link rel="stylesheet" type="text/css" href="http://picmg.mil-embedded.com/wp-content/themes/refresh/css/CPCI.css?1.1.1">
    <script type="text/javascript">
        var facebook_app_id = "158637600867272";
        var Topic = false;
        var addthis_share = {
            url_transforms : {
                shorten: {
                    twitter: 'bitly'
                }
            },
            shorteners : {
                bitly : {}
            }
        }
        var addthis_config =
            {
                ui_click: true,
                data_track_textcopy:true,
                data_track_clickback:false,
                data_ga_property: 'UA-91807-34',
                data_ga_social : true
                                ,services_custom:
                    {
                        name: "OpenSystems Media Reprints",
                        url: "http://www.wrightsmedia.com/sites/open-systems/dev/picmg/?urlx=http%3A%2F%2Fpicmg.mil-embedded.com%2Farticles%2Fmachine-vision-depends-on-open-industrial-standards%2F%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%253A%2Bcpci%2B%2528PICMG%2BSystems%2Band%2BTechnology%2BNews%2529&title=Machine%20vision%20depends%20on%20open%20industrial%20standards",
                        icon: "http://cloud1.opensystemsmedia.com/rubix16.png"
                    }
                            }
    </script>
    <!--<script type="text/javascript">less = { env: 'production' };</script>-->
    <link rel="alternate" type="application/rss+xml" title="PICMG Systems and Technology &raquo; Machine vision depends on open industrial standards Comments Feed" href="http://picmg.mil-embedded.com/articles/machine-vision-depends-on-open-industrial-standards/feed/" />
<link rel='stylesheet' id='content-css'  href='http://cloud2.opensystemsmedia.com/share/CSS/TechChannelFeed.css?ver=3.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='osm-styles-css'  href='http://cloud2.opensystemsmedia.com/share/CSS/osm-styles.css?ver=3.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='reset-css'  href='http://picmg.mil-embedded.com/wp-content/themes/refresh/css/reset.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='http://picmg.mil-embedded.com/wp-content/themes/refresh/css/fontawesome.css?ver=3.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='fonts-css'  href='http://fonts.googleapis.com/css?family=Oxygen%3A400%2C700%2C300&#038;subset=cyrillic-ext%2Ccyrillic%2Clatin-ext%2Clatin&#038;ver=3.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-css'  href='http://picmg.mil-embedded.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' />
<script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1.8.1/jquery.min.js?ver=1.8.1'></script>
<script type='text/javascript' src='http://cdnjs.cloudflare.com/ajax/libs/less.js/1.3.3/less.min.js?ver=1.3.3'></script>
<link rel='prev' title='COM-HPC: Limitless high-speed scalability' href='http://picmg.mil-embedded.com/articles/com-hpc-limitless-high-speed-scalability/' />
    <!--[if lt IE 9]>
    <script src="//html5shim.googlecode.com/svn/trunk/html5.js"></script>
    <![endif]-->

    <script type='text/javascript'>
        $.ajaxSetup ({
            // Disable caching of AJAX responses
            cache: true
        });
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        (function() {
            var gads = document.createElement('script');
            gads.async = true;
            gads.type = 'text/javascript';
            var useSSL = 'https:' == document.location.protocol;
            gads.src = (useSSL ? 'https:' : 'http:') +
                '//www.googletagservices.com/tag/js/gpt.js';
            var node = document.getElementsByTagName('script')[0];
            node.parentNode.insertBefore(gads, node);
        })();
    </script>

    <script type="text/javascript">
        if(typeof subsearch !== 'function') {

            
            function subsearch(box){
                if($('form.search #searchCheckbox').is(':checked')) {
                    window.location.href='http://picmg.mil-embedded.com/part-search/?q='+$(box).prop('value');
                    //if(location.pathname === '/part-search/') { window.location.reload(); }
                } else {
                    window.location.href='http://picmg.mil-embedded.com/search/?q='+$(box).prop('value');
                    if(location.pathname === '/search/') { window.location.reload(); }
                }
            }

            function searchPrep(box) {
                if($(box).prop('value')==='Search articles, news, and products...'){$(box).prop('value', '');}



                
            }

        }



    </script>

    <script type="text/javascript">
        var _ads = new Array();
        googletag.cmd.push(function() {
            _ads.push(googletag.defineSlot('/1007027/Medium_Rectangle', [300, 250], 'div-gpt-ad-1320948880618-0').addService(googletag.pubads()));
            _ads.push(googletag.defineSlot('/1007027/Leaderboard', [728, 90], 'div-gpt-ad-1319730952581-0').addService(googletag.pubads()));
            _ads.push(googletag.defineSlot('/1007027/Wide_Skyscraper', [160, 600], 'div-gpt-ad-1342804909615-0').addService(googletag.pubads()));
            _ads.push(googletag.defineSlot('/1007027/half_page', [300, 600], 'div-gpt-ad-1328031648097-0').addService(googletag.pubads()));
            // _ads.push(googletag.defineSlot('/1007027/Interstitial_init', [1, 1], 'div-gpt-ad-1332184629197-0').addService(googletag.pubads()));
            // _ads.push(googletag.defineSlot('/1007027/Peel_jquery', [2, 2], 'div-gpt-ad-1332196512882-0').addService(googletag.pubads()));
            _ads.push(googletag.defineSlot('/1007027/Medium_Rectangle_2', [300, 250], 'div-gpt-ad-1342540726547-0').addService(googletag.pubads()));
            // _ads.push(googletag.defineSlot('/1007027/Footer_JS_1', [3, 3], 'div-gpt-ad-1343754747321-0').addService(googletag.pubads()));
            //_ads.push(googletag.defineSlot('/1007027/Square_Button', [125, 125], 'div-gpt-ad-1346774474408-0').addService(googletag.pubads()));
            //_ads.push(googletag.defineSlot('/1007027/Square_Button_2', [125, 125], 'div-gpt-ad-1346774502103-0').addService(googletag.pubads()));
            _ads.push(googletag.defineSlot('/1007027/Square_Button_3', [125, 125], 'div-gpt-ad-1346774532986-0').addService(googletag.pubads()));
            _ads.push(googletag.defineSlot('/1007027/Square_Button_4', [125, 125], 'div-gpt-ad-1346774561716-0').addService(googletag.pubads()));
            //_ads.push(googletag.defineSlot('/1007027/Leaderboard_2', [728, 90], 'div-gpt-ad-1378313671446-0').addService(googletag.pubads()));
            _ads.push(googletag.defineSlot('/1007027/medium_rectangle_3', [300, 250], 'div-gpt-ad-1421164958161-0').addService(googletag.pubads()));
            _ads.push(googletag.defineSlot('/1007027/part_search_680x40', [680, 40], 'div-gpt-ad-1478190132757-0').addService(googletag.pubads()));
            _ads.push(googletag.defineSlot('/1007027/wallpaper_left', [140, 900], 'div-gpt-ad-1498579034921-1').addService(googletag.pubads()));
            _ads.push(googletag.defineSlot('/1007027/wallpaper_right', [140, 900], 'div-gpt-ad-1498579034921-2').addService(googletag.pubads()));

            // ADDED 4/18/19
            // $('.wallpaper').remove();
            // $('body').prepend('<div class="wallpaper advertisement"><div class="wallpaper-l"></div><div class="wallpaper-r"></div></div>');
            // $('.wallpaper .wallpaper-l').append("<div id='div-gpt-ad-1498579034921-1' style='height:900px; width:140px;'></div>");
            // $('.wallpaper .wallpaper-r').append("<div id='div-gpt-ad-1498579034921-2' style='height:900px; width:140px;'></div>");


            var mapping = googletag.sizeMapping().
            addSize([0, 0], [800, 400]).
            addSize([800, 600], [2000, 200]).
            build();

			var megaLeaderboard = googletag.defineSlot('/1007027/mega_leaderboard', [2000, 200], 'div-gpt-ad-1548872786659-0');
			googletag.pubads().addEventListener('slotRenderEnded', function(event) {
				if (event.slot === megaLeaderboard && !event.isEmpty) {
					// Slot specific logic
					$('.ad-resizer').addClass('slot-loaded');
				} // else {
				// 	console.log("Slot NOT loaded!!!");
				// }
			});

            _ads.push(megaLeaderboard.
            defineSizeMapping(mapping).
            setCollapseEmptyDiv(true).
            addService(googletag.pubads()));

            googletag.pubads().setTargeting("Magazine", "CPCI");
                        googletag.pubads().setTargeting("RequestURL", "articlesmachine-vision-depends-on-open-industrial-standards?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+cpci+%28PICMG+Systems+and+Technology+News%29");


            
        });
    </script>

    <script language="JavaScript">
			Topic = "embedded: processing";
		</script>
		
<script type="text/javascript">
googletag.cmd.push(function() {
	googletag.pubads().setTargeting("Keywords", ["image_pro","featur_e","image_enh","sensor_pr","radar","sonar","sensor_ar","field_arr","phased_ar","array_pro","edge_p","sensor","curren_t","voltag_e","mems_s","flow_s","gas meter","water_met","lidar","inerti_al","photoe_lec","positi_on","rate_s","electr_o-o","infrar_ed","fiber_opt","pressu_re","load cell","piezoe_lec","thermocoup","image_sen","machin_e","sensor_gr","sensor_no","video_sen","wirele_ss","analog_im","hypers_pec","nanosensor","unatte_nde","video_pro","interleavi","time-d_ivi","embedd_ed","open_s","picmg_sta"]);
		});
		</script><script type="text/javascript">
        var Topic_Keywords = ["image processing","feature extraction","image enhancement","sensor processing","radar","sonar","sensor array","field array","phased array","array processing","edge processing","sensor","current sensor","voltage detector","mems sensor","flow sensor","gas meter","water meter","lidar","inertial navigation system","photoelectric sensor","position sensor","rate sensor","electro-optical sensor","infrared sensor","fiber optic sensor","pressure sensor","load cell","piezoelectric sensor","thermocouple","image sensor","machine vision","sensor grid","sensor node","video sensor","wireless sensor network","analog image","hyperspectral sensor","nanosensor","unattended ground sensor","video processing","interleaving","time-division multiplexing","embedded: processing","machine vision depends open industrial standards","machine vision systems","open standards","picmg standards","Image Processing"," feature extraction"," image enhancement"," Sensor Processing"," radar"," sonar"," sensor array"," field array"," phased array"," array processing"," edge processing"," sensor"," current sensor"," voltage detector"," MEMS sensor"," flow sensor"," gas meter"," water meter"," LIDAR"," Inertial navigation system"," photoelectric sensor"," position sensor"," rate sensor"," electro-optical sensor"," infrared sensor"," fiber optic sensor"," pressure sensor"," load cell"," piezoelectric sensor"," thermocouple"," electro-optical sensor"," image sensor"," machine vision"," sensor grid"," sensor node"," video sensor"," wireless sensor network"," analog image"," hyperspectral sensor"," nanosensor"," unattended ground sensor"," radar"," sonar"," Video Processing"," image enhancement"," interleaving"," time-division multiplexing"];
        var dataLayer =
            [{
                'keywords':Topic_Keywords,
                'dynx_pagetype':'offerdetail',
                'dynx_itemid':Topic,
                'section':Topic
            }];
    </script>
    
    <script type="text/javascript">
        googletag.cmd.push(function() {
            //googletag.pubads().enableSingleRequest();
            googletag.enableServices();
        });

        function osm_channel_inferred() {
            initialize_follow_button();
        }
    </script>

    <script type="text/javascript">

        var local_dispatches = {};
        var _DISPATCH = {};

        jQuery.Dispatch = function( id ) {
            var callbacks,
                method,
                dispatch = id && local_dispatches[ id ];

            if ( !dispatch ) {
                callbacks = jQuery.Callbacks();
                dispatch = {
                    publish: callbacks.fire,
                    subscribe: callbacks.add,
                    unsubscribe: callbacks.remove
                };
                if ( id ) {
                    local_dispatches[ id ] = dispatch;
                }
            }
            return dispatch;
        };

        $(document).ready(function() {

            _DISPATCH.connect_js_loaded = {
                deferred_dispatch: $.Deferred(),
                dispatch: $.Dispatch( "connect_js_loaded" )
            };

            _DISPATCH.connect_js_loaded.deferred_dispatch.done( _DISPATCH.connect_js_loaded.dispatch.publish );

            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
                (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
                m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
            })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

            ga('create', 'UA-91807-34', 'auto', {'allowLinker': true} );
            ga('send', 'pageview',
                {
                    'hitCallback': function() {
                        $.getScript('/connect.php?action=js2', function() {
                            _DISPATCH.connect_js_loaded.deferred_dispatch.resolve( 'connect_js_loaded' );
                        });
                    }
                }
            );
        });


        
    </script>

    <meta property="og:type" content="article"/>
<meta property="article:section" content="articles" />
<meta property="article:tag" content="" />
    


</head>

<body class="CPCI">
<div class="wallpaper advertisement" style="
"><div class="wallpaper-l">
        <div id="div-gpt-ad-1498579034921-1" style="height:900px; width:140px;">
            <script>
                googletag.cmd.push(function() { googletag.display('div-gpt-ad-1498579034921-1'); });
            </script>
        </div>
    </div>
    <div class="wallpaper-r">
        <div id="div-gpt-ad-1498579034921-2" style="height:900px; width:140px;">
            <script>
                googletag.cmd.push(function() { googletag.display('div-gpt-ad-1498579034921-2'); });
            </script>
        </div>
    </div>
</div>

<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-T37QQZ"
                  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
            new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-T37QQZ');</script>
<!-- End Google Tag Manager -->

<style>
    @media (max-width: 720px) {
        #super-leaderboard .ad-resizer {
            max-width: 720px;
            min-width: 280px;
        }
    }

    @media (min-width: 721px) {
        #super-leaderboard .ad-resizer {
            max-width: 1920px;
            min-width: 721px;
        }
    }

    @media (max-width: 720px) {
        #super-leaderboard .ad-resizer.slot-loaded::before {
            padding-top: 50%;
        }
    }

    @media (min-width: 721px) {
        .ad-resizer.slot-loaded::before {
            padding-top: 10%;
        }
    }


    .ad-resizer::before {
        content: '';
        display: block;
    }

    #super-leaderboard .ad-content > div, #super-leaderboard .ad-content iframe {
        height: 100%!important;
        position: relative;
        width: 100%!important;
        z-index: 100;
    }

    .wallpaper {
        position: fixed;
        left: 0px;
        display: none;
        margin: 0px;
        overflow: visible;
    }

    @media screen and (min-width: 1024px) {
        .wallpaper {
            display: block;
        }
    }

    .wallpaper .wallpaper-l, .wallpaper .wallpaper-r { width: 140px; height: 900px; z-index: 90; position: fixed; }
    .wallpaper .wallpaper-l, .wallpaper .wallpaper-r, .wallpaper div, .wallpaper iframe, .wallpaper * { z-index: 90; }
    .wallpaper .wallpaper-l {
        left: 15px;
        bottom: 0;
    }
    .wallpaper .wallpaper-r {
        right: 15px;
        bottom: 0;
    }
</style>

<div id="super-leaderboard" style="
    display: -webkit-box;
    display: -ms-flexbox;
    display: flex;
    -ms-flex-pack: center;
    -webkit-box-pack: center;
    justify-content: center;
    -ms-flex-align: center;
    -webkit-box-align: center;
    align-items: center;
    overflow: hidden;
    position: relative;
    text-align: center;
    z-index: 1;
">
    <div class="ad-resizer" style="
    background-color: #fee;
    position: relative;
    height: 100%;
    width: 100%;
    background-color: white;
">
        <div class="ad-content" id="div-gpt-ad-1548872786659-0" style="
    height: 100%;
    left: 0;
    overflow: hidden;
    position: absolute;
    top: 0;
    width: 100%;
">
            <!-- /1007027/mega_leaderboard -->
            <script>
                googletag.cmd.push(function() { googletag.display('div-gpt-ad-1548872786659-0'); });
            </script>

        </div>
    </div>
</div>

        <div id="top-bar">
        <div class="container">


            <div class="leaderboard">
	<div id="div-gpt-ad-1319730952581-0">
		<script type="text/javascript">
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1319730952581-0'); });
		</script>
	</div>
</div><!-- .leaderboard -->
                            <div class="mag-promo" id="rtp-zone-mag-promo">

                                            <img src="http://cloud1.opensystemsmedia.com/Ai-osm_logo_tiny_light_white.gif" class="tiny-logo" style="float: right;margin: -7px 0px -11px 0px;" />

                        <ul>
                            <li class="subscribe"><a href="http://opensystemsmedia.com/subscriptions/new/">Free Subscription</a></li>
                                                            <li><a class="latest-issue" href="http://picmg.mil-embedded.com/issuu/?issuu_id=aHR0cHM6Ly9pc3N1dS5jb20vb3BlbnN5c3RlbXNtZWRpYS9kb2NzL3BpY21nLnNwcjE5cmdfZmluYWw/ZT0xMTg3NTkyMS82NzIzNDYzOAo=">See the Current Issue</a></li>
                            
                                                            <li><a class="archived-issues" href="/emag/">Archived Issues</a></li>
                                                    </ul>
                        <div class="mag-covers">
                            <img src="http://i.opensystemsmedia.com/?fltr[]=over|images/glint3.png|0|0|100&fltr[3]=usm|50|3|0.3&q=95&w=59&h=80&src=http%3A%2F%2Fimac.opensystemsmedia.com%2Ffmi%2Fxml%2Fcnt%2FPICMG%2520Spr19RG%2520Cover.jpg%3F-db%3Demag%26-lay%3Demag%26-recid%3D740%26-field%3Dcover%281%29" alt="PICMG Systems and Technology" height="80" width="59" />
                            <img src="http://i.opensystemsmedia.com/?fltr[]=over|images/glint3.png|0|0|100&fltr[3]=usm|50|3|0.3&q=95&w=59&h=80&src=http%3A%2F%2Fimac.opensystemsmedia.com%2Ffmi%2Fxml%2Fcnt%2FCover.pdf%3F-db%3Demag%26-lay%3Demag%26-recid%3D730%26-field%3Dcover%281%29" alt="PICMG Systems and Technology" alt="" />
                            <img src="http://i.opensystemsmedia.com/?fltr[]=over|images/glint3.png|0|0|100&fltr[3]=usm|50|3|0.3&q=95&w=59&h=80&src=http%3A%2F%2Fimac.opensystemsmedia.com%2Ffmi%2Fxml%2Fcnt%2FPICMG%2520Spr18RG%2520Cover.jpg%3F-db%3Demag%26-lay%3Demag%26-recid%3D704%26-field%3Dcover%281%29" alt="PICMG Systems and Technology" alt="" />
                        </div><!-- .mag-covers -->
                        <div id="square-button-ads">
                            <div id="div-gpt-ad-1346774532986-0" class="wrapper even">
                            </div>

                                                            <div id="div-gpt-ad-1346774561716-0" class="wrapper odd">
                                </div>
                                                    </div>


                    
                </div><!-- .mag-promo -->
            

        </div><!-- .container -->
    </div><!-- #top-bar -->

    <header class="main">

        <a href="http://picmg.mil-embedded.com" class="logo"><img src="http://picmg.mil-embedded.com/wp-content/themes/refresh/images/logo-CPCI.png" alt="PICMG Systems and Technology" height="60" /></a>
        <nav class="pre-nav">
            <form onsubmit="subsearch('#searchBox');return false;" class="search">
                <input class="text" onclick="searchPrep('#searchBox');" type="text" id="searchBox" value="Search articles, news, and products..." speech x-webkit-speech />
                <button type="submit"><i class="icon-search"></i></button>
            </form>
            <nav class="content-types"><ul><li id="menu-item-8111" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8111 articles"><a href="/articles/">Articles</a></li>
<li id="menu-item-8115" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8115 authors"><a href="/authors-list/">Authors</a></li>
<li id="menu-item-8112" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8112 white-papers"><a href="/white-papers/">White Papers</a></li>
<li id="menu-item-8113" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8113 products"><a href="/products/">Products</a></li>
<li id="menu-item-8114" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8114 news"><a href="/news/">News</a></li>
<li id="menu-item-8313" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8313 blog"><a href="/blog/">Blog</a></li>
</ul></nav>        </nav>

        <!-- AddThis Button END -->
        <div class="follow">
            <div class="addthis_toolbox addthis_32x32_style addthis_default_style" addthis:url="http://picmg.mil-embedded.com">
                <ul>
                    <li class="facebook"><a class="addthis_button_facebook_follow" addthis:userid="pages/CompactPCI-AdvancedTCA-and-MicroTCA-Systems/270690113015655"><i class="icon-facebook-sign icon-large"></i></a></li>
                                            <li class="twitter"><a class="addthis_button_twitter_follow" addthis:userid="xtca_atca"><i class="icon-twitter-sign icon-large"></i></a></li>
                                        <li class="linkedin"><a class="addthis_button_linkedin_follow" addthis:url="http://picmg.mil-embedded.com/linkedin"><i class="icon-linkedin-sign icon-large"></i></a></li>
                    <li class="googleplus"><a class="addthis_button_google_follow" addthis:userid="100481914706650211876"><i class="icon-google-plus-sign icon-large"></i></a></li>
                    <li class="rss"><a class="addthis_button_rss_follow" addthis:url="http://m.opensystemsmedia.com/cpci"><i class="icon-rss icon-large"></i></a></li>
                </ul>
            </div>
        </div><!-- .follow -->

        <nav class="main">

            <ul class="topics"><li class="home"><a href="http://picmg.mil-embedded.com"><i class="icon-home icon-large"></i></a></li><li id="menu-item-8106" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8106 xtca"><a href="/topics/xtca">xTCA</a></li>
<li id="menu-item-8107" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8107 com-express"><a href="/topics/com-express">COM Express</a></li>
<li id="menu-item-8108" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8108 compactpci"><a href="/topics/compactpci">CompactPCI</a></li>
<li id="menu-item-8109" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8109 lte"><a href="/topics/lte">LTE</a></li>
<li id="menu-item-8110" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8110 embedded-software"><a href="/topics/embedded-software">Embedded Software</a></li>
</ul>
            <ul class="issue">
                <li><a href="javascript:void(0)"><i class="icon-reorder"></i></a></li>
                                    <li><a href="https://opensysmedia.com/solutions/webcasts/calendar">Webcasts</a></li>
                    <li><a href="http://picmg.mil-embedded.com/eletter/">E-Letter</a></li>
                            </ul>
        </nav>

    </header><!-- .main -->

<section class="main">	
				<div id="skinny-column">
						<div class="skyscraper">
	<div id="div-gpt-ad-1342804909615-0">
		<script type="text/javascript">
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1342804909615-0'); });
		</script>
	</div>
</div><!-- .skyscraper -->		</div><!-- #skinny-column -->
				
		<article >
		
			
						
			<h1>Machine vision depends on open industrial standards</h1>
			
			<div id="content" class="stickem-container">
				
					

<div class="authors noimage"><span class="author"><a href="http://picmg.mil-embedded.com/author/herdnat/" title="Posts by Herbert Erd, NAT" rel=""><span itemscope itemtype="http://schema.org/Person"><meta itemprop="url" content="http://picmg.mil-embedded.com/author/herdnat/"/><meta itemprop="image" content="http://picmg.mil-embedded.com/wp-content/themes/refresh/images/mystery-man.png"/><img src="http://picmg.mil-embedded.com/wp-content/themes/refresh/images/mystery-man.png"   border="0" />Herbert Erd, NAT</span></a><div class="addthis_toolbox addthis_default_style"><a class="addthis_button_rss_follow" addthis:url="http://picmg.mil-embedded.com/author/herdnat/feed/"></a></div></span></div>


<div class="comment-share"><div class="addthis_sharing_toolbox"  data-title="Machine vision depends on open industrial standards" style="display: inline-block;margin-right:15px;"></div><button class="show-comments"><span class="disqus-comment-count" data-disqus-url="http://picmg.mil-embedded.com/articles/machine-vision-depends-on-open-industrial-standards/?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+cpci+%28PICMG+Systems+and+Technology+News%29"></span> - <b>Leave a Comment</b></button></div>


				
				
				<div>				
				<span itemprop="articleBody" class="body">
				<a href="http://i.opensystemsmedia.com/?zc=0&f=png&w=1225&src=http%3A%2F%2Fi.opensystemsmedia.com%2F%3Fw%3D450%26f%3Djpg%26q%3D94%26src%3Dhttp%253A%252F%252Fmes-wp-uploads.s3.amazonaws.com%252F5e4c3c002b7f6-NAT%252BErd%252Bposs%252Blead.jpg" target="_blank"><img border="0" alt="" class="figure_intro right" src="http://i.opensystemsmedia.com/?zc=1&f=png&w=225&fltr[]=wmt|%EF%81%8C|18|BR|FFFFFF|Webdings.ttf|100|2|0|000000|50|&src=http%3A%2F%2Fi.opensystemsmedia.com%2F%3Fw%3D450%26f%3Djpg%26q%3D94%26src%3Dhttp%253A%252F%252Fmes-wp-uploads.s3.amazonaws.com%252F5e4c3c002b7f6-NAT%252BErd%252Bposs%252Blead.jpg" /></a><p class=abstract>For the past 15-plus years, optical inspection – also called machine
vision – has expanded worldwide, leaving its footprint in different vertical
markets. These days machine vision is mainly performed in three ways: offline,
where parts are removed from the manufacturing process; near-line, during which
parts are inspected close to the manufacturing process, leading to a quicker
return to the production line; and online, where components are inspected
without removing from the manufacturing process.</p>

<p class=BodyText1>Machine vision is used in automation for failure detection
and quality inspection, while in medical markets its main purpose is picture
analysis and merging. In addition, the public safety and transportation industries
use machine-vision technology for camera link aggregation, filtering,
analytics, compression, and recoding. </p>

<p class=BodyText1>Input sensors used in machine-vision applications can
consist of different kinds of cameras for the visible or invisible spectrum;
they may also include ultrasonic and X-ray laser sensors, or even a combination
of any of these. </p>

<p class=BodyText1>The amount of data per input link (bandwidth) as well as the
number of links are growing with every new camera generation, because of 3D
capabilities as well as real-time requirements with low latency.</p>

<p class=BodyText1>In order to terminate and process such data streams from
different sensor types, hardware based on FPGAs has become very popular for
image processing, particularly when latency matters. On top of existing
applications, growing demands from AI [artificial intelligence] as well as the IoT
[Internet of Things] will increase the need for processing power and
intelligent interconnects. Any new feature has an additional impact on data
input, throughput, processing and data output, which means that every development
team should consider several aspects before choosing any specific hardware
platform.</p>

<h2>Developers’ headache</h2>

<p class=BodyText1>For machine vision, two types of software developers – with completely
different backgrounds – are involved for solutions based on FPGAs. First off,
digital image-processing engineers or C programmers may have limited hardware
skills; in addition, real FPGA programmers can be hard to find. Developers in
this realm must understand the overall effects of the software requirements on
the suitable hardware platform for a system in production.</p>

<p class=BodyText1>As a first approach, we often see FPGA-based PCIe cards in a
PC, actually still one of the most common development environments with a
simple master/slave architecture.</p>

<p class=BodyText1>However, the following simple calculation might highlight
the limitation of such a development environment: In a typical machine vision
application, a camera generates a data stream of 672 Mbit/sec (2.4 Mpix/frame x
35 frames/s x 8 bit/pix = 672 Mbit/sec). </p>

<p class=BodyText1>This data stream needs to be terminated by a processing
resource whereby the image gets further manipulated and processed. In order to
transport the data stream from the camera to the processing engine, in this
case a 1 GbE link on GiGE (GbE vision) is sufficient. </p>

<p class=BodyText1>Upgrading the camera to a more enhanced version could easily
increase the data stream from 672 Mbit/sec to 4.5 Gbit/sec to be transported (5.2
Mpix/frame x 107 frames/s x 8 bit/pix = 4.5 Gbit/sec). </p>

<p class=BodyText1>So it’s fair to assume that with any new or additional
sensor being added to the system, the data stream between camera and processing
device increases significantly. Therefore, one can conclude that a growing
demand for bandwidth will soon drive the chosen processing engine to its limit.
As a consequence, a system design with a fixed and dedicated number of I/O ports
and processing engines – either CPUs or FPGAs by design – can soon generate
major issues for the performance and/or ability to upgrade of systems deployed
to the field. This is a typical development issue.</p>

<h2>Machine vision based on MicroTCA for embedded applications</h2>

<p class=BodyText1>N.A.T. developed its distinctive NATvision platform concept based
on the open industrial standard MicroTCA for embedded applications in
industrial, medical, transportation, and public safety markets. NATvision
enables users to have a complete environment for development amd serial
production of sophisticated image- and video-processing applications. </p>

<p class=BodyText1>The platform consists of a wide range of different FPGA and
CPU boards fully integrated in different proven MicroTCA chassis and is
intended to reduce both development costs and time. </p>

<p class=BodyText1>It uses a set of preselected software tools with different
libraries to optimize FPGA/Arm-based programming for machine vision. For larger
systems that need high-speed interconnects between different boards plus timing
and trigger signals, MicroTCA’s switching and clocking capability provides
scalability and flexibility for Machine Vision applications. Add-on
requirements during the system life cycle can also be implemented.</p>

<p class=BodyText1>By combining proven hardware components with Visual Applets,
NATvision eliminates the need for deep FPGA knowledge. Visual Applets (design
software) is a graphical design tool for creating and programming image-processing
algorithms on FPGA hardware. Vision algorithms are described by block design
operators, available from included libraries. Due to a platform-specific glue
logic layer, HDL [Hardware Description Language], skills are not required. This
capability enables engineers to focus on the vision algorithm, thus achieving
impressive results in very short time. (Figure 1.)</p>

<table width="480" border="0" cellspacing="0" cellpadding="2" align="center">
<tbody>
<tr>
<td align="center">
<p class="Heading-1"><img src="http://i.opensystemsmedia.com/?w=450&f=jpg&q=94&src=http%3A%2F%2Fmes-wp-uploads.s3.amazonaws.com%2F5e4c3c92cab14-Figure%2B1%2BNAT%2BVisual%2BApplets.pdf" alt="21" width="470" border="0" /></p>
</td>
</tr>
<tr>
<td class="caption" style="padding-top: 10px;line-height: 1em" align="center">
<figcaption><strong>Figure 1</strong> | Visual Applets enables creation and programming of
image-processing algorithms on FPGA hardware without the need for HDL
knowledge.</figcaption></td>
</tr>
</tbody>
</table>

<p class=BodyText1>NATvision allows combining any HDL-based logic with software
libraries such as OpenCV or Halcon to expand the field of possible
applications. Software algorithms can either run on an external CPU (x86, x64)
or on the system-on-chip’s processing system (Arm).  </p>

<p class=BodyText1>It is even possible to accelerate software algorithms with
an FPGA. This can be done by using high level synthesis (HLS), which compiles C
code into HDL language. By using FGPA resources instead of executing algorithms
sequentially on a CPU, image processing can be accelerated by multiples of 10.
This is mainly archived by rolling out loops into parallel logic structures.
Developers will benefit from HLS as it is much easier to describe and test HDL
algorithms when they’re written in C. </p>

<p class=BodyText1>Today, NATvision is available with different FPGAs from
Xilinx and Altera including FMC (FPGA mezzanine cards)-based I/O. In order to
meet special customer requirements, different processing engines such as x86
and RISC-/ARM-based CPUs are available. (Figure 2.)</p>
<table width="480" border="0" cellspacing="0" cellpadding="2" align="center">
<tbody>
<tr>
<td align="center">
<p class="Heading-1"><img src="http://i.opensystemsmedia.com/?w=450&f=jpg&q=94&src=http%3A%2F%2Fmes-wp-uploads.s3.amazonaws.com%2F5e4c3cb2066a2-Figure%2B2%2BNAT%2BNAT%2BVision%2Btool%2Bwith%2Bcd.jpg" alt="21" width="470" border="0" /></p>
</td>
</tr>
<tr>
<td class="caption" style="padding-top: 10px;line-height: 1em" align="center">
<figcaption><strong>Figure 2</strong> | NATvision is customizable with different FPGAs, software libraries, and more.</figcaption></td>
</tr>
</tbody>
</table>

<h2>What’s the benefit?</h2>

<p class=BodyText1>Based on N.A.T.’s NATvision platform, any development of new
algorithms can start immediately and independent from the final system design.
Due to NATvision’s flexibility, several parameters and solution characteristics
can be easily altered during development – for example, amount and types of
cameras, sensor resolution, frames per second, processing power, or new
functions for the foreseen application – as well as the addition of new and
additional output requirements without delaying the application development in
any way. </p>

<p class=BodyText1>The deployment system for serial production can be designed
independently and in parallel to the software development based on a small
NATvision development system. Based on Mi-croTCA’s design rules, larger
enclosures for additional cards can also be used. High-speed switching
capability enables handling whatever number of boards in a flexible manner. If
needed, new or more powerful functions can be implemented by adding hardware in
spare slots by reconfiguring the board to board communication via the switch.
In this way, software tasks also can be split or distributed between different
boards.</p>

<p class=BodyText1>NATvision provides flexibility in several ways: </p>

<p class=bullets><span style='font-family:Symbol'>·<span style='font:7.0pt "Times New Roman"'>&nbsp;&nbsp;&nbsp;&nbsp;
</span></span>Provides scalability in terms of number and types of boards.</p>

<p class=bullets><span style='font-family:Symbol'>·<span style='font:7.0pt "Times New Roman"'>&nbsp;&nbsp;&nbsp;&nbsp;
</span></span>Provides independence of hardware requirements from software
application development</p>

<p class=bullets><span style='font-family:Symbol'>·<span style='font:7.0pt "Times New Roman"'>&nbsp;&nbsp;&nbsp;&nbsp;
</span></span>Provides a graphical software-development tool and enables the
use of C and C++ codes instead of HDL</p>

<p class=bullets><span style='font-family:Symbol'>·<span style='font:7.0pt "Times New Roman"'>&nbsp;&nbsp;&nbsp;&nbsp;
</span></span>Enables distribution of application functions afterwards, even
for different boards</p>

<p class=bullets><span style='font-family:Symbol'>·<span style='font:7.0pt "Times New Roman"'>&nbsp;&nbsp;&nbsp;&nbsp;
</span></span>Timing and latency aspects are covered by hardware</p>

<p class=bullets><span style='font-family:Symbol'>·<span style='font:7.0pt "Times New Roman"'>&nbsp;&nbsp;&nbsp;&nbsp;
</span></span>Remote management and system health are also covered as standard
functions by design</p>

<p class=bullets><span style='font-family:Symbol'>·<span style='font:7.0pt "Times New Roman"'>&nbsp;&nbsp;&nbsp;&nbsp;
</span></span>On-the-fly support for modular hardware without impact on the
used software leads to scalable, flexible, and future-proven systems solutions.
</p>

<h2>Companies’ machine-vision needs can change</h2>

<p class=BodyText1>Today’s machine-vision systems are facing additional and/or
changing requirements during the development process already, even after
deployment during their lifespan. For industrial applications, an open
industrial standard like MicroTCA provides the needed flexibility to extend
hardware as needed. NATvision – based on this approach – supports development
and deployment and naturally provides software tools for remote upgrades.</p>

<p class=BodyText1>NATvision enables a change of hardware if required,
independent of whether new I/O requirements show up or additional or more
powerful processing cards are needed. As soon as a common clock domain is
required, a MicroTCA-based vision system proves its worth, as this scenario
enables even distribution of a system across several enclosures located in
different areas. </p>

<p class=authorbio>Herbert Erd is the Business Development Manager at N.A.T.
With 35 years business experience and 15+ years of experience in business
development, Herbert has an extensive technical background in embedded,
automation/IoT, and communication technology. Since 2005 he has initiated and
designed several major mTCA and ATCA projects for communication and automation
applications. He holds an engineering degree from the University of Applied Sciences
for Electronic and Radio Communication Academic -- grade of graduate engineer --
at FH Koblenz.</p>

<p class=contactinfo>N.A.T. · www.nateurope.com</p>

</div>

</body>

</html>				</span>
				
				<script type="text/javascript">
    
    $("article .keywords").before('<time class="date">This article was published on February 18<sup>th</sup>, 2020.</time>');
    
    
        
    $("article .keywords").before('<div class="comment-share"><a href="http://picmg.mil-embedded.com/articles/machine-vision-depends-on-open-industrial-standards/?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+cpci+%28PICMG+Systems+and+Technology+News%29#disqus_thread" style="display: none;"></a><div class="addthis_sharing_toolbox" data-title="Machine vision depends on open industrial standards" style="display: inline-block;margin-right:15px;"></div><button class="show-comments"><span class="disqus-comment-count" data-disqus-url="http://picmg.mil-embedded.com/articles/machine-vision-depends-on-open-industrial-standards/?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+cpci+%28PICMG+Systems+and+Technology+News%29"></span> - <b>Leave a Comment</b></button></div><div id="disqus_thread"></div>');
    
    
    
    
    /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
    var disqus_shortname = 'com'; // required: replace example with your forum shortname
	var disqus_url = 'http://picmg.mil-embedded.com/articles/machine-vision-depends-on-open-industrial-standards/?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+cpci+%28PICMG+Systems+and+Technology+News%29';
	
	
	
	var disqus_config = function () {
    	this.callbacks.onNewComment = [function(comment) { 
			//alert(comment.id);
			//alert(comment.text);
			ga('send', 'event', 'Comments', 'Reader left comment', 1);
    	}];
	}
	 
    /* * * DON'T EDIT BELOW THIS LINE * * */
    //(function() {
    //    var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
    //    dsq.src = 'http://' + disqus_shortname + '.disqus.com/embed.js';
    //    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
    //})();
    
    function loadDisqus() {
	    $.ajax({
				type: "GET",
				url: "http://" + disqus_shortname + ".disqus.com/embed.js",
				dataType: "script",
				cache: true
			});	
	}
    
	$(document).ready(function() {
		$('.show-comments').on('click', function(){
			// ajax request to load the disqus javascript
			if($('#disqus_thread').height()<1) {
				loadDisqus();
			}
			$('html, body').animate({
				scrollTop: $("#disqus_thread").offset().top
			}, 2000);
			// hide the button once comments load	
			$('.show-comments').fadeOut();
			ga('send', 'event', 'Comments', 'Expand Comments', 1);
		});
	
		$.ajax({
			type: "GET",
			url: "http://" + disqus_shortname + ".disqus.com/count.js",
			dataType: "script",
			cache: false
		});
	
		setTimeout( function() {
			if($('.disqus-comment-count').text().indexOf('0 Comments')<0) {
				loadDisqus();
			}
		}, 4000); 
	});
    
</script>			
			</div><!-- #content -->
			
						<div id="stream-column">
				<div id="current-topic">
					<h3><a href="#">Advertisement</a><a style="margin-left: 12px; font-size: 11px; color: #C5DCC4;" onclick="$('#stream-column').remove();">[<span style="text-decoration: underline;">x</span>]</a></h3>
					<ul class="TechChannelFeed small">
					</ul>
				</div><!-- #current-topic -->
				
				<div class="square" id='div-gpt-ad-1320948880618-0'>
	<script type='text/javascript'>
	googletag.cmd.push(function() { googletag.display('div-gpt-ad-1320948880618-0'); });
	</script>
</div><!-- .square  -->			</div><!-- #stream-column -->
						
		</article>

	</section><!-- .main -->
<div class="footer_leaderboard">
	<div class="container">
		
				<div class="ad">
			<!-- medium_rectangle_3 -->
			<div id='div-gpt-ad-1421164958161-0' style='width:300px; height:250px; margin-top: 12px;'>
			<script type='text/javascript'>
				googletag.cmd.push(function() { googletag.display('div-gpt-ad-1421164958161-0'); });
			</script>
			</div>
		</div><!-- .ad -->
			</div>
</div>
	<footer>
		<div class="container">
			<a href="" class="title">PICMG Systems and Technology</a>

			<!-- AddThis Button END -->
			<div class="follow">
				<div class="addthis_toolbox addthis_32x32_style addthis_default_style" addthis:url="http://picmg.mil-embedded.com">
					<ul>
						<li class="facebook"><a class="addthis_button_facebook_follow" addthis:userid="pages/CompactPCI-AdvancedTCA-and-MicroTCA-Systems/270690113015655"><i class="icon-facebook-sign icon-large"></i></a></li>
												<li class="twitter"><a class="addthis_button_twitter_follow" addthis:userid="xtca_atca"><i class="icon-twitter-sign icon-large"></i></a></li>
																								<li class="googleplus"><a class="addthis_button_google_follow" addthis:userid="100481914706650211876"><i class="icon-google-plus-sign icon-large"></i></a></li>
												<li class="rss"><a class="addthis_button_rss_follow" addthis:url="http://m.opensystemsmedia.com/cpci"><i class="icon-rss icon-large"></i></a></li>
						<li class="youtube"><a class="addthis_button_youtube_follow" addthis:url="https://www.youtube.com/channel/UCMaskSJiCICHOkGB-vR7_xw"><i class="icon-youtube-sign icon-large"></i></a></li>
					</ul>
				</div>
			</div><!-- .follow -->

			<nav class="main">
				<ul class="topics"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8111 articles"><a href="/articles/">Articles</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8115 authors"><a href="/authors-list/">Authors</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8112 white-papers"><a href="/white-papers/">White Papers</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8113 products"><a href="/products/">Products</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8114 news"><a href="/news/">News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8313 blog"><a href="/blog/">Blog</a></li>
</ul>			</nav>

			
			
							<div class="awards">
				<a href="http://picmg.org" target="_blank"><img src="http://osmphp.s3.amazonaws.com/picmg-award.png" alt="PICMG Open Modular Computing Specifications" /></a>				</div><!-- #awards -->
			
			
			<p class="copyright">&copy; <a href="https://opensysmedia.com" target="_blank">OpenSystems Media</a></p>

			<nav>
				<ul>
					
					<li><a href="">Home</a></li>
					
					<li><a class="archived-issues" href="/emag/">Archived Issues</a></li>
					
					<li><a href="https://opensysmedia.com/about">About</a></li>
					
					<li><a href="https://opensysmedia.com/advertise">Advertise</a></li>
					
					
                                            <li><b><a href="http://mil-embedded.com/submit/">Submit News and Products</a></b></li>
                    					
					<li><a href="https://opensysmedia.com/privacy">Privacy Policy</a></li>

					<li><a href="https://opensysmedia.com/contact">Contact</a></li>
					
				</ul>
			</nav>
			
						<p class="refresh">Last updated: <a href="http://445b87df-2b97-4263-bc48-bfc63002f354.scalr.ws/post/scalr/varnish/purge_host_token.php?host=picmg.mil-embedded.com&token=%5E%2Farticles%2Fmachine-vision-depends-on-open-industrial-standards%2F%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%253A%2Bcpci%2B%2528PICMG%2BSystems%2Band%2BTechnology%2BNews%2529%24" target="_blank">Fri, 28 Feb 2020 13:52:08 +0000</a> http://picmg.mil-embedded.com/articles/machine-vision-depends-on-open-industrial-standards/</p>
		</div><!-- .container -->
	</footer>

<script type='text/javascript' src='http://cloud2.opensystemsmedia.com/share/JS/easydate.min.js?ver=3.4.2'></script>
<script type='text/javascript' src='http://picmg.mil-embedded.com/wp-content/themes/refresh/js/navigation.js?ver=3.4.2'></script>
<script type='text/javascript' src='http://picmg.mil-embedded.com/wp-content/themes/refresh/js/article-scroll.js?ver=3.4.3'></script>
<script type='text/javascript' src='http://cloud2.opensystemsmedia.com/share/JS/jquery.stickem.js?ver=3.4.2'></script>
<script type='text/javascript' src='http://cloud2.opensystemsmedia.com/share/JS/waypoints.min.js?ver=3.4.2'></script>
<script type='text/javascript' src='http://cloud2.opensystemsmedia.com/share/JS/jstickem-init.js?ver=4'></script>

<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

_qevents.push({
qacct:"p-65tksMXFN9wIU"
});
</script>

<noscript>
	<div style="display:none;">
		<img src="//pixel.quantserve.com/pixel/p-65tksMXFN9wIU.gif" border="0" height="1" width="1" alt="Quantcast"/>
	</div>
</noscript>
<!-- End Quantcast tag -->

<div id="fb-root"></div>

<style type="text/css">
</style>

<!-- Peel_jquery -->
<div id='div-gpt-ad-1332196512882-0' style='width:2px; height:2px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1332196512882-0'); });
</script>
</div>
<!-- Footer_JS_1 -->
<div id='div-gpt-ad-1343754747321-0' style='width:3px; height:3px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1343754747321-0'); });
</script>
</div>


<!-- Interstitial_init -->
<div id='div-gpt-ad-1332184629197-0' style='width:1px; height:1px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1332184629197-0'); });
</script>
</div>

<script>
    (function() {

        window.addEventListener("resize", resizeThrottler, false);

        var resizeTimeout;
        function resizeThrottler() {
            // ignore resize events as long as an actualResizeHandler execution is in the queue
            if ( !resizeTimeout ) {
                resizeTimeout = setTimeout(function() {
                    resizeTimeout = null;
                    actualResizeHandler();

                    // The actualResizeHandler will execute at a rate of 15fps
                }, 99);
            }
        }

        function actualResizeHandler() {
            // handle the resize event
            googletag.pubads().refresh();
            // console.log("Ads refreshed!!!");
        }

    }());
</script>

</body>

</html>